2007年2月27日星期二

一目图------飞狐主图指标

{一目图------飞狐主图指标}

{云雾}
AA:=(HHV(HIGH,120)-LLV(LOW,120))/30,LINETHICK;
Yw1:=(3*C+H+L+O)/6;
Yw2:=HHV(MA(Yw1,5),13);
Yw3:=(HHV(H,1)+LLV(L,1))/2;
Yw4:=REF((HHV(H,52)+LLV(L,52))/2,1);
Yw5:=IF(Yw4>Yw2,Yw4,Yw2);
Yw6:=IF(ma(Yw1,10)<REF(Yw3,1),REF(Yw3,1),ma(Yw1,10));
STICKLINE(REF(Yw3,1)<Yw4,REF(Yw3,1),Yw4,0.1,0),COLOR339933;
STICKLINE(REF(Yw3,1)>=Yw4,REF(Yw3,1),Yw4,0.1,0),COLOR0033CC;
STICKLINE(MA(Yw1,5)<Yw2,Yw4,Yw2,0,0),COLOR9FBC7D;
PARTLINE(C,IF(Yw4<=REF(Yw3,1),Yw4,REF(Yw3,1))),COLORGRAY;
PARTLINE(C,IF(Yw5<Yw6,Yw6,Yw5)),COLORGRAY;
{K线}
fo:=if(checkuser(1),o,0);
fh:=if(checkuser(1),h,0);
fl:=if(checkuser(1),l,0);
fc:=if(checkuser(1),c,0);
<%
vo=ffl.vardata("fo")
vh=ffl.vardata("fh")
vl=ffl.vardata("fl")
vc=ffl.vardata("fc")
last=ubound(vc)
vc(0)=(vh(0)+vl(0)+2*vc(0))/4
for i=1 to last
vo(i)=(vo(i-1)+vc(i-1))/2
if vo(i)>vh(i) then vh(i)=vo(i) else vh(i)=vh(i)
if vo(i)<vl(i) then vl(i)=vo(i) else vl(i)=vl(i)
vc(i)=(2*vc(i)+vh(i)+vl(i))/4
next
ffl.vardata("fo")=vo
ffl.vardata("fh")=vh
ffl.vardata("fl")=vl
ffl.vardata("fc")=vc
%>
kk:=if(fc>=fo and (fc>=ref(fc,1) or ref(fc,1)>=ref(fo,1)),1,if(fc<fo and (fc<ref(fo,1) or ref(fc,1)<ref(fo,1)),-1,0));
明:=(fo+fc)/2,shift1,colorff00;//--------------
转:=if(kk=1,min(fc,fo),if(kk=-1,max(fc,fo),if(ref(kk,1)=1,min(fc,fo),if(ref(kk,1)=-1,max(fc,fo),(fc+fo)/2))));
stickline(kk=1,min(fo,fc),min(fo,fc)+abs(fc-fo)*1/8,8,0),colorff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*1/8,min(fo,fc)+abs(fc-fo)*2/8,8,0),color33ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*2/8,min(fo,fc)+abs(fc-fo)*3/8,8,0),color66ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*3/8,min(fo,fc)+abs(fc-fo)*4/8,8,0),color99ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*4/8,min(fo,fc)+abs(fc-fo)*5/8,8,0),colorbbff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*5/8,min(fo,fc)+abs(fc-fo)*6/8,8,0),colorccff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*6/8,min(fo,fc)+abs(fc-fo)*7/8,8,0),coloreeff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*7/8,min(fo,fc)+abs(fc-fo)*8/8,8,0),colorffff;
stickline(kk=-1,min(fo,fc),min(fo,fc)+abs(fc-fo)*1/8,8,0),colorffff;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*1/8,min(fo,fc)+abs(fc-fo)*2/8,8,0),colorffee00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*2/8,min(fo,fc)+abs(fc-fo)*3/8,8,0),colorffcc00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*3/8,min(fo,fc)+abs(fc-fo)*4/8,8,0),colorffaa00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*4/8,min(fo,fc)+abs(fc-fo)*5/8,8,0),colorff8800;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*5/8,min(fo,fc)+abs(fc-fo)*6/8,8,0),colorff6600;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*6/8,min(fo,fc)+abs(fc-fo)*7/8,8,0),colorff3300;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*7/8,min(fo,fc)+abs(fc-fo)*8/8,8,0),colorff0000;
stickline(fc>fo,fh,fc,0.4,0),colorff;
stickline(fc>fo,fo,fl,0.4,0),colorff;
stickline(fo>fc,fh,fo,0.4,0),colorffff00;
stickline(fo>fc,fc,fl,0.4,0),colorffff00;
stickline(kk=0 and fc>=fo,fo,fc,8,1),colorff00ff;
stickline(kk=0 and fc<fo,fo,fc,8,0),colorff00ff ;


--
一步一步教你从互联网赚钱
http://www.zqzn.com/index.asp?rid=key480769

没有评论: