2007年3月8日星期四

真假黑马识别器 , 主力做盘

http://bbs.macd.cn/viewthread.php?tid=1045389
真假黑马识别+主力作盘(<带图>)
 
    现在已经凌晨1点呢,这几天很忙,所以发的公式没有检测,弄出很多错误,现在全做了改正和测试,为表示歉意,特再加一原码(方法自己琢磨,很直观),如果有朋友有什么不爽的地方,请针对公式别针对人!拜托!谢谢!   
发此贴同时在此感谢论坛老师和高手\朋友们的指点和帮助!感谢论坛提供我们交流的平台! 
[ 使用方法:当指标发出"黑马"两字时,要结合量指标中变色红白线,"黑马"出现在变色线红色线时,信号可以信赖,出现在白色线时,要继续观察!同时绿色线要和变色线前期形成金叉!(公式还存在缺点,可继续优化,谢谢
 
                                             真假黑马识别器
收益:(FINANCE(33)),colorwhite;
净资产:(FINANCE(34));
现流通盘:((FINANCE(7))/(10000)),color806080;
RSV:=(((CLOSE - LLV(LOW,21))/(HHV(HIGH,21) - LLV(LOW,21)))*(100));
趋势:(MA((3)*(SMA(RSV,6,1)) - (2)*(SMA(SMA(RSV,5,1),5,1)),2)),Linethick2,coloryellow;
VAR2:=(3)*(SMA(((OPEN - LLV(LOW,89))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1)) - (2)*(SMA(SMA(((OPEN - LLV(LOW,89))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1),15,1));
VAR3:=VAR2 - 100;
背离:(FORCAST(((-1))*(VAR3),21)),Linethick2,Color9933FF;
DRAWTEXT((CROSS(趋势,背离)),背离,'黑马'),colorred;
DRAWTEXT((CROSS(背离,趋势)),背离,'↓ '),Color00FF00;
发现天数:(BARSLAST((趋势 < 背离))),colorff80ff;
DRAWTEXT(((趋势)/(背离) > 8) and (背离 < 10) and (趋势 > 80),(趋势)*(1.12),'走'),Color00FF00;
DRAWTEXT((背离< 5) and (趋势 > 60),趋势*1.12,'逃'),Colorwhite;
量:=(EMA(IF(C>=REF(C,2),V,(-V)),34)/MA(V,34))*100;
量9:EMA(量,9),COLOR00FF00;
X26:=EMA(量,26),COLORFF00FF;
STICKLINE(X26>=REF(X26,1), X26, X26,8,0),COLORRED,LINETHICK2;
STICKLINE(X26<REF(X26,1), X26, X26,8,0),COLORWHITE,LINETHICK2;
 

第2个主力做盘
 
主力做盘轨迹:(((CLOSE - MA(LLV(LOW,40),40)) / MA(LLV(LOW,40),40)) * 100),colorF0F000;
BIAS1 : (CLOSE-MA(CLOSE,9))/MA(CLOSE,9)*100,colorwhite;
坚决买:=(主力做盘轨迹-BIAS1)<5.5;
DRAWTEXT(坚决买 ,38,'金子 '),COLORf0ff00;
stickline (坚决买 ,0,30,5,0),colorred;
AA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*1000;
BB:=MA(AA,10);
趋势线:SMA(BB,3,1)/10,linethick2,colorred;
JNYY2:=(((CLOSE - LLV(LOW,26)) / (HHV(HIGH,26) - LLV(LOW,26))) * 100);
判断:SMA(JNYY2,32,1)-20,color00ff00,linethick1;
买:DRAWTEXT(CROSS(趋势线,判断),趋势线+10,'买▲牛'),LINETHICK2,colorwhite;
建仓:DRAWTEXT(CROSS(判断,趋势线),判断,'建▲仓'),LINETHICK2,coloryellow;
不怕死:DRAWTEXT(CROSS(主力做盘轨迹,判断),判断-10,'加▲码'),LINETHICK2,colorred;
 
这是能引入的
 
收益: (FINANCE(33)),colorwhite;
净资产: (FINANCE(34));
现流通盘: ((FINANCE(7))/(10000)),color806080;
VAR88:=1;
RSV:=(((CLOSE - LLV(LOW,21))/(HHV(HIGH,21) - LLV(LOW,21)))*(100))*(VAR88);
趋势: (MA((3)*(SMA(RSV,6,1)) - (2)*(SMA(SMA(RSV,5,1),5,1)),2))*(VAR88),Linethick2,coloryellow;
VAR2:=(3)*(SMA(((OPEN - LLV(LOW,89))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1)) - (2)*(SMA(SMA(((OPEN - LLV(LOW,89))/(HHV(HIGH,89) - LLV(LOW,89)))*(100),20,1),15,1));
VAR3:=VAR2 - 100;
背离: (FORCAST(((-1))*(VAR3),21))*(VAR88),Linethick2,Color9933FF;
DRAWTEXT((CROSS(趋势,背离))*(VAR88),背离,'黑马'),colorred;
DRAWTEXT((CROSS(背离,趋势))*(VAR88),背离,'↓ '),Color00FF00;
发现天数: (BARSLAST((趋势 < 背离)))*(VAR88),colorff80ff;
DRAWTEXT(((趋势)/(背离) > 8) and (背离 < 10) and (趋势 > 80),(趋势)*( 1.12),'走'),Color00FF00;
DRAWTEXT((背离 < 5) and (趋势 > (60)*(VAR88)),(趋势)*(1.12),'逃'),Colorwhite;
量:=(EMA(IF(C>=REF(C,2),V,(-V)),34)/MA(V,34))*100;
量9:EMA(量,9),COLOR00FF00;
X26:=EMA(量,26),COLORFF00FF;
STICKLINE(X26>=REF(X26,1), X26, X26,8,0),COLORRED,LINETHICK2;
STICKLINE(X26<REF(X26,1), X26, X26,8,0),COLORWHITE,LINETHICK2;
 


--
一步一步教你从互联网赚钱
http://www.zqzn.com/index.asp?rid=key480769

没有评论: