2007年3月7日星期三

几个MACD相关的公式

飞狐特色指标MACD实战(解盘)源码
 
 
 

input:LONG(26,20,100),SHORT(12,5,40),M(9,2,60);
DIFF:=(EMA(CLOSE,SHORT) - EMA(CLOSE,LONG));
DEA:=EMA(DIFF,M);
MACD2:=(2 * (DIFF - DEA));
VERTLINE(((CLOSE < 0) AND CROSS(DIFF,0))),color80;
VERTLINE(((CLOSE < 0) AND CROSS(MACD2,0))),color80;
VERTLINE(((CLOSE < 0) AND CROSS(0,DIFF))),color808080;
VERTLINE(((CLOSE < 0) AND CROSS(0,MACD2))),color808080;
DU0:=CROSS(DIFF,0);
UD0:=CROSS(0,DIFF);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF((TDU3 < TUD3),REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));
JDU0:=(((REF(CLOSE,1) <= REF(UDGLINE,1)) AND (CLOSE > UDGLINE)) AND (TDU0 < TUD0));
JUD0:=(((REF(CLOSE,1) >= REF(UDGLINE,1)) AND (CLOSE < UDGLINE)) AND (TUD0 < TDU0));
JDU1:=(JDU0 AND (COUNT(JDU0,TDU0) = 1));
JUD1:=(JUD0 AND (COUNT(JUD0,TUD0) = 1));
JDU2:=(JDU1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));
JUD2:=(JUD1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));
JDU3:=(JDU1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));
JUD3:=(JUD1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));
BSLINE:=IF((BARSLAST(JDU2) < BARSLAST(JUD2)),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));
DRAWICON((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),0,10),ALIGN4;
DRAWICON((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))),0,11),ALIGN5;
STICKLINE((MACD2 >= 0),0,MACD2,6,1),colorFF;
STICKLINE(((MACD2 >= 0) AND (MACD2 < REF(MACD2,1))),0,MACD2,6,0),COLORCYAN;
STICKLINE((MACD2 < 0),0,MACD2,6,0),colorFFFF00;
STICKLINE(((MACD2 < 0) AND (MACD2 > REF(MACD2,1))),0,MACD2,6,1),COLORRED;
STICKLINE((CLOSE > 0),0,0,10,0),color808080;
DIF:DIFF,LINETHICK2,colorFFFF;
DEF:DEA,colorFF00;
MACD:MACD2,LINETHICK0,colorFFFF00;
DEFUT:=BARSLAST(CROSS(MACD2,0));
DEFDT:=BARSLAST(CROSS(0,MACD2));
DEFUL:=IF((MACD2 >= 0),HHV(MACD2,(DEFUT + 1)),REF(HHV(MACD2,(DEFUT + 1)),(DEFDT + 1)));
DEFDL:=IF((MACD2 < 0),LLV(MACD2,(DEFDT + 1)),REF(LLV(MACD2,(DEFDT + 1)),(DEFUT + 1)));
DEFU2L:=REF(DEFUL,(DEFUT + 1));
DEFD2L:=REF(DEFDL,(DEFDT + 1));
DRAWICON(((((LLV(MACD2,4) > 0) AND (MACD2 < REF(MACD2,1))) AND (REF(MACD2,1) > REF(MACD2,2))) AND (REF(MACD2,2) > REF(MACD2,3))),MACD2,5),ALIGN0;
DRAWICON(((((HHV(MACD2,4) < 0) AND (MACD2 > REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) < REF(MACD2,3))),MACD2,4);
DRAWICON(((((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))) AND (MACD2 >= 0)) AND (REF(MACD2,1) < REF(DEFU2L,1))) AND (MACD2 > DEFU2L)),MACD2,12),ALIGN0;
DRAWICON(((((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND (MACD2 < 0)) AND (REF(MACD2,1) > REF(DEFD2L,1))) AND (MACD2 < DEFD2L)),MACD2,12);
EXPLAIN(JDU2,'注意长线趋势空转多');
EXPLAIN(JUD2,'注意长线趋势多转空');
EXPLAIN((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),'长线为多头趋势');
EXPLAIN((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))),'长线为空头趋势');
EXPLAINEX((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),'MACD多头防守价',BSLINE,2,1);
EXPLAINEX((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))),'MACD空头防守价',BSLINE,2,1);
EXPLAIN(((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND (CLOSE < BSLINE)),'防守价跌破:多头小心');
EXPLAIN(((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))) AND (CLOSE > BSLINE)),'防守价突破:空头小心');
EXPLAIN(((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))) AND CROSS(MACD2,0)),'空头注意今明两日高点压力\n找日落K线放空,用线控盘');
EXPLAIN(((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND CROSS(0,MACD2)),'多头注意今明两日低点支撑\n找日出K线做多,用线控盘');
EXPLAIN(((((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))) AND (MACD2 >= 0)) AND (REF(MACD2,1) < REF(DEFU2L,1))) AND (MACD2 > DEFU2L)),'DEF柱状特殊研判\n空头注意今明两日高点压力');
EXPLAIN(((((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND (MACD2 < 0)) AND (REF(MACD2,1) > REF(DEFD2L,1))) AND (MACD2 < DEFD2L)),'DEF柱状特殊研判\n多头注意今明两日低点支撑');
EXPLAINEX((REF((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))),1) AND CROSS(REF(MACD2,1),0)),'空头注意压力',HHV(HIGH,2),2,1);
EXPLAIN((REF((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))),1) AND CROSS(REF(MACD2,1),0)),'找日落K线放空,用线控盘');
EXPLAINEX((REF((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),1) AND CROSS(0,REF(MACD2,1))),'多头注意支撑',LLV(LOW,2),2,1);
EXPLAIN((REF((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),1) AND CROSS(0,REF(MACD2,1))),'找日出K线进场,用线控盘');
EXPLAIN(((((LLV(MACD2,4) > 0) AND (MACD2 < REF(MACD2,1))) AND (REF(MACD2,1) > REF(MACD2,2))) AND (REF(MACD2,2) > REF(MACD2,3))),'请注意DEF柱状缩头');
EXPLAIN(((((HHV(MACD2,4) < 0) AND (MACD2 > REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) < REF(MACD2,3))),'请注意DEF柱状缩脚');
MA1:=((2*C+(12-1)*EMA(C,12))/(12+1))-((2*C+(26-1)*EMA(C,26))/(26+1));
MA2:=(2*MA1+(9-1)*DEA)/(9+1);
[MACD预测]:2*(MA1-MA2),LINETHICK0,COLORRED;
 
 
 
{MACD 实战逃顶}
DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA  : EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK;
D1:=EMA(C,3)-EMA(C,8);
D2:=EMA(O,3)-EMA(O,8);
D3:=EMA(H,3)-EMA(H,8);
D4:=EMA(L,3)-EMA(L,8);
DRAWICON(cross(diff,d1) and diff>0.1 ,d3+0.1,2);
STICKLINE(D1>=D2,D1,D2,8,0),COLOR0055AA;
STICKLINE(D1<=D2,D1,D2,8,0),COLOR006600;
STICKLINE(D1>=D2,D1,D2,5,0),COLOR0077CC;
STICKLINE(D1>=D2,D1,D2,3,0),COLOR0099DD;
STICKLINE(D1>=D2,D3,D4,0,0),COLOR00BBFF;
STICKLINE(D1<=D2,D1,D2,5,0),COLOR009900;
STICKLINE(D1<=D2,D1,D2,3,0),COLOR00BB00;
STICKLINE(D1<=D2,D3,D4,0,0),COLOR00EE00;
 
 
{MACD实战破译}
{参数 :SHORT  12、  LONG  26、  M   9}
 
INPUT:SHORT(12,1,100,1),LONG(26,1,100,1), M(9,1,100,2);
 
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
MACD:EMA(DIF,M),COLOR58FF58;
DEF:2*(DIF-MACD),COLORFFFF00,LINETHICK0;
STICKLINE(DEF>=0 AND DEF>=REF(DEF,1),0,DEF,6,1),COLOR6058FF;
STICKLINE(DEF>=0 AND DEF< REF(DEF,1),0,DEF,6,0),COLOR6058FF;
STICKLINE(DEF<0 AND DEF>=REF(DEF,1),0,DEF,6,1),COLORFFFF00;
STICKLINE(DEF<0 AND DEF< REF(DEF,1),0,DEF,6,0),COLORFFFF00;
PARTLINE(DIF<1000,0),COLORBROWN;
多头趋势:=IF(DIF>=0 AND MACD>=0 OR (DIF<0 AND MACD>=0),1,0);
空头趋势:=DIF<0 AND MACD<0 OR (DIF>=0 AND MACD<0);
缩头:=IF(DEF>0 AND REF(DEF,1)>REF(DEF,2) AND DEF< REF(DEF,1),1,0);
缩脚:=IF(DEF<0 AND REF(DEF,1)< REF(DEF,2) AND DEF>REF(DEF,1),1,0);
阻力:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),1,0);
支撑:=IF(CROSS(MA(C,20),C) OR CROSS(MA(C,60),C),1,0);
做多:=IF(CROSS(MACD,DIF) AND DIF>0 AND MACD>0,1,0);
放空:=IF(CROSS(DIF,MACD) AND DIF<0 AND MACD<0,1,0);
DRAWICON(多头趋势,DIF,10),ALIGN4;
DRAWICON(空头趋势,DIF,11),ALIGN5;
PARTLINE(DIF<1000,DIF),,COLORCCFFFF,LINETHICK2;
PARTLINE(MACD<1000,MACD),COLOR58FF58;
DRAWICON(FILTER(缩头,3) AND 缩头,DEF+0.01,5),ALIGN0;
DRAWICON(FILTER(缩脚,3) AND 缩脚,DEF,4),ALIGN1;
DRAWICON(FILTER(阻力,16) AND DEF>=0,DEF+0.01,12),ALIGN0;
DRAWICON(FILTER(支撑,16) AND DEF<0,DEF,12),ALIGN1;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
EXPLAIN(多头趋势, ''§§§长线为多头趋势§§§§''),COLORRED;
EXPLAIN(空头趋势, ''§§§长线为空头趋势§§§§''),COLORGREEN;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
EXPLAIN(缩头, ''§请注意DEF柱状缩头''),COLORFFFF00;
EXPLAIN(缩脚, ''§请注意DEF柱状缩脚''),COLORFFFF00;
EXPLAIN(FILTER(支撑,16) AND DEF<0, ''§DEF柱状特殊研判''),COLORFFFF00;
EXPLAIN(做多=0 AND FILTER(支撑,16) AND DEF<0, ''§多头注意今明两日低点支撑''),COLORFFFF00;
EXPLAIN(FILTER(阻力,16) AND DEF>=0, ''§DEF柱状特殊研判''),COLORFFFF00;
EXPLAIN(放空=0 AND FILTER(阻力,16) AND DEF>=0, ''§空头注意今明两日高点压力''),COLORFFFF00;
EXPLAIN(做多, ''§多头注意今明两日低点支撑''),COLORFFFF00;
EXPLAIN(做多, ''§找日出K线做多,用线控盘''),COLORFFFF00;
EXPLAIN(放空, ''§空头注意今明两日高点压力''),COLORFFFF00;
EXPLAIN(放空, ''§找日落K线放空,用线控盘''),COLORFFFF00;
EXPLAIN(CROSS(MACD,0), ''§注意长线趋势空转多''),COLORRED;
EXPLAIN(CROSS(0,MACD), ''§注意长线趋势多转空''),COLORGREEN;
A:=C>=REF(C,2);
B:=C< REF(C,2);
ZA:=BARSLAST(A);
ZB:=BARSLAST(B);
LA:=REF(L,ZA);
HB:=REF(H,ZB);
EXPLAIN(多头趋势 AND C< LA, ''§防守价跌破:多头小心''),COLORRED;
EXPLAIN(空头趋势 AND C>HB, ''§防守价突破:空头小心''),COLORRED;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
EXPLAINEX(多头趋势, ''MACD多头防守价:'',LA,2,0),COLOR3399FF ;
EXPLAINEX(空头趋势, ''MACD空头防守价:'',HB,2,0),COLOR3399FF ;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
EXPLAIN((COUNT(C>REF(C,1),30)>18 AND (COUNT(C>REF(C,1),3)=3)) AND (COUNT(DEF< REF(DEF,1),30)>18),''§反转--股价将可能反转向下''),COLOR58FF58;
EXPLAIN((COUNT(C< REF(C,1),30)>18 AND (COUNT(C< REF(C,1),3)=3)) AND (COUNT(DEF>REF(DEF,1),30)>18),''§反转--股价将可能反转向上''),COLOR58FF58;
EXPLAIN(DEF<0 AND ABS(DEF)>REF(ABS(DEF),1),''§MACD绿柱增长''),COLOR58FF58;
EXPLAIN(DEF<0 AND ABS(DEF)< REF(ABS(DEF),1),''§MACD绿柱缩短''),COLOR58FF58;
EXPLAIN(DEF>0 AND DEF>REF(DEF,1),''§MACD红柱增长''),COLOR58FF58;
EXPLAIN(DEF>0 AND DEF< REF(DEF,1),''§MACD红柱缩短''),COLOR58FF58;
EXPLAIN((LLV(L,60)=L) AND (NOT(LLV(MACD,60)=MACD)),''§底背离--属买入信号''),COLOR58FF58;
EXPLAIN((HHV(H,60)=H) AND (NOT(HHV(MACD,60)=MACD)),''§顶背离--属卖出信号''),COLOR58FF58;
EXPLAIN(CROSS(MACD,DIF) AND MACD<0,''§MACD在0轴下死叉''),COLOR58FF58;
EXPLAIN(CROSS(DIF,MACD) AND MACD<0,''§MACD在0轴下金叉''),COLOR58FF58;
EXPLAIN(CROSS(DIF,MACD),''§金叉--属买入信号''),COLOR58FF58;
EXPLAIN(CROSS(MACD,DIF),''§死叉--属卖出信号''),COLOR58FF58;
EXPLAIN(CROSS(DIF,MACD) AND MACD>0,''§MACD在0轴上金叉''),COLOR58FF58;
EXPLAIN(CROSS(MACD,DIF) AND MACD>0,''§MACD在0轴上死叉''),COLOR58FF58;
EXPLAIN(CROSS(DIF,MACD) AND CROSS(DEF,0),''§上穿0轴,可考虑买入''),COLOR58FF58;
EXPLAIN(FILTER(CROSS(DIF,MACD) AND MACD>0,13),''§高位金叉''),COLOR58FF58;
EXPLAIN(FILTER(CROSS(DIF,MACD) AND MACD<0,6),''§低位金叉''),COLOR58FF58;
EXPLAIN(COUNT(CROSS(DIF,MACD) AND MACD>0,20)=2 AND CROSS(DIF,MACD) AND
MACD>0,''§0轴上二次金叉''),COLOR58FF58;
EXPLAIN(COUNT(CROSS(DIF,MACD) AND MACD>0,20)=3 AND CROSS(DIF,MACD) AND
MACD>0,''§0轴上三次金叉''),COLOR58FF58;
EXPLAIN(COUNT(CROSS(DIF,MACD) AND MACD>0,20)=4 AND CROSS(DIF,MACD) AND MACD>0,''§0轴上四次金叉''),COLOR58FF58;
EXPLAIN(COUNT(CROSS(MACD,DIF),20)=2 AND CROSS(MACD,DIF),''§二次死叉,跌幅可能较深''),COLOR58FF58;
EXPLAIN(COUNT(CROSS(DIF,MACD),20)=2 AND CROSS(DIF,MACD),''§二次金叉,涨幅可能较大''),COLOR58FF58;
EXPLAIN(DIF>=0 AND DEF>=0 AND DEF<=REF(DEF,1),''§上涨趋势有所减缓,短线投资者可逢高卖出,但当回落至均线或其他支撑位时应及时回补''),COLOR58FF58;
EXPLAIN(DIF<0 AND DEF>0 AND DEF>REF(DEF,1),''§目前正处于反弹阶段,应保持谨慎''),COLOR58FF58;
EXPLAIN(DEF>0 AND DIF>0 AND DIF>MACD AND DIF>REF(DIF,1) AND C>REF(C,1),''§上升趋势尚未改变''),COLOR58FF58;
EXPLAIN(DIF<0 AND DEF>0 AND DEF< REF(DEF,1),''§短线反弹已经结束,应继续坚持谨慎原则''),COLOR58FF58;
EXPLAIN(DIF<0 AND DEF<=0 AND DEF< REF(DEF,1),''§有加速下跌趋势''),COLOR58FF58;
EXPLAIN(DIF<0 AND DEF<=0 AND DEF>=REF(DEF,1),''§下跌趋势有所减缓,可在W&R指标大于90时逢低买入,但有可能再次加速下跌,注意及时止损''),COLOR58FF58;
EXPLAIN(DEF<0 AND DIF<0 AND DIF< MACD AND DIF< REF(DIF,1) AND C< REF(C,1),''§下降趋势尚未改变''),COLOR58FF58;
EXPLAIN(DIF>=0 AND DEF>=0 AND DEF>REF(DEF,1),''§有加速上涨趋势''),COLOR58FF58;
EXPLAIN(DIF>=0 AND DEF<0 AND DEF< REF(DEF,1),''§目前正处于回落整理阶段,且回落有加速趋势''),COLOR58FF58;
EXPLAIN(DIF>=0 AND DEF<0 AND DEF>=REF(DEF,1),''§目前正处于回落整理阶段,但整理即将结束,可在均线或其他支撑位附近逢低买入,但当整理完成后选择再次向下突破时应注意及时止损''),COLOR58FF58;
EXPLAIN(DEF<-0.35,''§超卖中,随时有可能反弹''),COLOR58FF58;
EXPLAIN(DEF>0.35,''§股价超买中,随时有可能回档''),COLOR58FF58;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
G:=26;
S:=12;
CC:=CLOSE;
ESS:=EMA(CC,12);
EGG:=EMA(CC,12);
RDIF:=REF(DIF,1);
RSS:=REF(ESS,1);
RGG:=REF(EGG,1);
RMACD:=REF(MACD,1);
RDEF:=REF(DEF,1);
RZZZ:=(RMACD+((M+1)/(2*(M-1)))*RDEF);
XDIF:=((G-1)*(S+1)*RGG-(G+1)*(S-1)*RSS+(S+1)*(G+1)*RDIF)/(2*G-2*S);
XMACD:=((G-1)*(S+1)*RGG-(G+1)*(S-1)*RSS+(S+1)*(G+1)*RMACD)/(2*G-2*S);
XDEF:=((G-1)*(S+1)*RGG-(G+1)*(S-1)*RSS+(S+1)*(G+1)*RZZZ)/(2*G-2*S);
AA:=ISLASTBAR;
BB:=BACKSET(AA=1,1);
Y:=BARSLAST(BB=1);
X:=Y+1;
TDIF:=DIF*X;
TSS:=ESS*X;
TGG:=EGG*X;
TMACD:=MACD*X;
TDEF:=DEF*X;
TZZZ:=(TMACD+((M+1)/(2*(M-1)))*TDEF);
YDIF:=((G-1)*(S+1)*TGG-(G+1)*(S-1)*TSS+(S+1)*(G+1)*TDIF)/(2*G-2*S);
YMACD:=((G-1)*(S+1)*TGG-(G+1)*(S-1)*TSS+(S+1)*(G+1)*TMACD)/(2*G-2*S);
YDEF:=((G-1)*(S+1)*TGG-(G+1)*(S-1)*TSS+(S+1)*(G+1)*TZZZ)/(2*G-2*S);
EE:=1;
EXPLAINEX(EE=1,''§DIF....今日转折'',XDIF,2,1),COLORCCFFFF ;
EXPLAINEX(EE=1,''§MACD今日转折'',XMACD,2,1),COLOR3399FF ;
EXPLAINEX(EE=1,''§DEF...今日转折'',XDEF,2,1),COLORFF9966 ;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
EXPLAINEX(EE=1,''§DIF....明日转折'',YDIF,2,1),COLORCCFFFF;
EXPLAINEX(EE=1,''§MACD明日转折'',YMACD,2,1),COLOR3399FF;
EXPLAINEX(EE=1,''§DEF...明日转折'',YDEF,2,1),COLORFF9966;
EXPLAIN(DIF<1000,''----------------------------------------------------------------------------''),COLORBROWN;
 
 

10 条评论:

匿名 说...

Thanks a lot for sharing this with all of us you
really understand what you are speaking about!
Bookmarked. Please also visit my website =). We could have a hyperlink
alternate agreement between us
Also visit my page ; australian online casino

匿名 说...

An impressive share! I've just forwarded this onto a friend who has been doing a little homework on this. And he actually ordered me lunch because I stumbled upon it for him... lol. So let me reword this.... Thanks for the meal!! But yeah, thanx for spending the time to talk about this topic here on your website.

Also visit my blog post: Best online casino

匿名 说...

Thanks to my father who stated to me concerning this
web site, this website is truly awesome.



Also visit my blog post ... Top online casino

匿名 说...

Hello there! This is my first visit to your
blog! We are a collection of volunteers and starting a new project in a community
in the same niche. Your blog provided us useful information
to work on. You have done a marvellous job!

Look at my site ... Online casino

匿名 说...

Good web site you have here.. It's difficult to find high quality writing like yours nowadays. I seriously appreciate people like you! Take care!!

Also visit my site Top online casino

匿名 说...

I'll right away seize your rss as I can't to find your email subscription hyperlink or newsletter service.

Do you've any? Please permit me know so that I could subscribe. Thanks.

Also visit my web site ... Top online casino

匿名 说...

What's Going down i'm new to this, I stumbled upon this I've discovered It positively useful and it has helped me out loads. I hope to contribute & help other customers like its aided me. Great job.

Here is my website: http://www.kickstarter.com/

匿名 说...

This info is worth everyone's attention. Where can I find out more?

My site ... Top online casino

匿名 说...

It's the best time to make a few plans for the long run and it is time to be happy. I've read this
publish and if I may just I want to recommend you few interesting things or advice.
Perhaps you can write subsequent articles relating to this
article. I want to learn more things about it!



Feel free to visit my weblog - Online casino Australia

匿名 说...

What's up, after reading this amazing paragraph i am as well glad to share my familiarity here with mates.

Also visit my homepage ... casinos online